Conversations Application Notification
Incident Report for Aerialink
Resolved
This incident has been resolved.
Posted May 05, 2021 - 11:52 CDT
Identified
There is a known Daylight Savings Time (DST) issue that may be affecting some users, resulting in times displayed being off by 1 hour. This is only a display issue, all features are working with proper times. We are investigating this issue.
Posted Mar 25, 2021 - 11:15 CDT
This incident affected: Conversations (Engine and Portal).