Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 09, 2025 - 21:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 06, 2025 - 00:30 PST
Scheduled
T-Mobile will be performing emergency maintenance impacting short code SMS and MMS services.
The maintenance is scheduled to begin Tuesday, December 9, 2025 at 9:00 PM PT and to finish December 10, 2025 by 3:00 AM PT. During the maintenance window, customers may experience intermittent latency impacting inbound (MO) and outbound (MT) SMS and MMS messaging via short code with T-Mobile subscribers.
Please see the list of impacted products and/or components below and contact the Convey Help Desk with any questions.
Posted Dec 05, 2025 - 23:58 PST
This scheduled maintenance affected: Message Delivery.