Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 08, 2024 - 22:00 CDT
Scheduled
The short code delivery hub received notice that T-Mobile will be performing an unplanned maintenance September 08, 2024 at 10 PM CT. During the maintenance window, there may be latency for SMS.
Posted Sep 04, 2024 - 14:53 CDT
This scheduled maintenance affected: Message Delivery.