Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 04, 2025 - 19:30 PST
Scheduled
AT&T will be performing a planned maintenance impacting toll-free MMS messaging services.
During the maintenance window, customers may experience intermittent latency to inbound (MO) & outbound (MT) MMS messaging with AT&T via toll-free.
We acknowledge AT&T's short notice on this maintenance. The toll-free vendor has indicated they are working with AT&T to obtain more timely notification in the future.
Posted Nov 03, 2025 - 13:51 PST
This scheduled maintenance affected: Message Delivery.