Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 29 days ago. Feb 12, 2025 - 22:00 CST
Scheduled
The toll-free delivery hub will be performing a planned maintenance on February 12, 2025, at 10 PM CST. During this maintenance window, there may be intermittent delivery delays for SMS and MMS.
Posted 30 days ago. Feb 12, 2025 - 08:26 CST
This scheduled maintenance affected: Message Delivery.