Vendor Incident - SMS Delivery Delays - Region IRAQ - ASIA

Incident Report for Aerialink

Resolved

This incident has been resolved.
Posted Dec 23, 2025 - 02:25 PST

Update

We are continuing to investigate this issue.
Posted Dec 23, 2025 - 02:24 PST

Investigating

There is a carrier-partner incident currently impacting Aerialink SMS services for the country IRAQ (ASIA)

Customers may experience intermittent delivery delays impacting inbound (MO) and outbound (MT) SMS messaging to this country.

The cause of this issue is under investigation at this time.

Please see the list of impacted products and/or services below and contact the Convey Help Desk with any questions. We will provide more information as it becomes available.
Posted Dec 22, 2025 - 16:49 PST
This incident affected: Message Delivery.