Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 05, 2026 - 18:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 05, 2026 - 11:45 PDT
Scheduled
T-Mobile will be performing scheduled maintenance impacting short code,10 DLC - SMS and MMS services.
The maintenance is scheduled to begin Sunday, April 5, 2026 at 6:00 PM PT and to finish April 6, 2026 by 5:00 AM PT. During the maintenance window, customers may experience intermittent latency impacting inbound (MO) and outbound (MT) SMS and MMS via Route 1 and Route 2 all sender types with T-Mobile subscribers.
Please see the list of impacted products and/or components below and contact the Convey Help Desk with any questions.
Posted Apr 05, 2026 - 11:33 PDT
This scheduled maintenance affected: Message Delivery.