Aerialink Incident - Aerialink Sms Delivery Delay for Isle of Man - Manx Telecom

Incident Report for Aerialink

Update

We are continuing to investigate this issue.
Posted Mar 12, 2026 - 08:55 PDT

Investigating

There is a vendor incident currently impacting Aerialink SMS services for Isle of Man - Manx Telecom.

Customers may experience an intermittent delivery delay at this time.

The cause of this issue is currently under investigation.

Please see the list of impacted products and/or services below and contact the Convey Help Desk with any questions. We will provide more information as it becomes available.
Posted Mar 12, 2026 - 05:50 PDT
This incident affects: Message Delivery.