Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 05, 2025 - 22:00 PST
Scheduled
T-Mobile will be performing an emergency maintenance impacting short code (route 1) SMS messaging/MMS messaging services on November 5, 2025 at 20:00 PST.
During the maintenance window, customers may experience minor latency to inbound (MO) & outbound (MT) SMS and MMS messaging with T-Mobile via short code (route 1).
Posted Nov 03, 2025 - 15:37 PST
This scheduled maintenance affected: Message Delivery.