Long Code Service Degradation

Incident Report for Aerialink

Resolved

The 10DLC delivery hub has confirmed this issue has been resolved.
Posted Apr 25, 2025 - 10:27 CDT

Identified

The 10DLC delivery hub has identified an issue resulting in MT, MO, and DLR message latency. We will provide more information as it becomes available.
Posted Apr 23, 2025 - 08:12 CDT
This incident affected: Message Delivery.