Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2025 - 19:00 CDT
Scheduled
The toll-free delivery hub will be performing a planned maintenance on March 15, 2025, at 7 PM CDT. During this maintenance window, there may be intermittent delivery delays for SMS and MMS.
Posted Mar 11, 2025 - 07:53 CDT
This scheduled maintenance affected: Message Delivery.