Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 16, 2025 - 12:00 PST
Scheduled
A toll-free carrier partner will be performing scheduled maintenance impacting toll-free SMS services.
The maintenance is scheduled to begin Sunday, November 16, 2025 at 12:00 PM PT and to finish November 16, 2025 by 3:00 PM PT. During the maintenance window, customers may experience intermittent delivery delays impacting SMS messaging via toll-free.
Please see the list of impacted products and/or components below and contact the Convey Help Desk with any questions.
Posted Nov 11, 2025 - 12:40 PST
This scheduled maintenance affected: Message Delivery.