Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2025 - 21:01 PST
Scheduled
The short code delivery hub received noticed that Verizon will be performing a planned maintenance November 12, 2025 at 11 PM CT. This maintenance will impact a subset of Convey short codes (Route 1). During this maintenance window, there may be SMS latency.
Posted Nov 03, 2025 - 12:51 PST
This scheduled maintenance affected: Message Delivery.