Aerialink Service Degradation - SMS/MMS

Incident Report for Aerialink

Resolved

Aerialink engineering has confirmed the issue has been resolved. All services are functioning as expected.
Posted Nov 10, 2025 - 13:25 PST

Monitoring

We are no longer observing message latency. Our Engineering team implemented corrective action to restore normal operations. All services are now functioning as expected. We will continue to monitor the environment closely to ensure stability.
Posted Nov 10, 2025 - 12:09 PST

Investigating

We are currently observing degraded performance impacting Aerialink. Customers may experience widespread message latency and responses with "too many requests" messages. Our Engineering team is actively investigating the issue and working to restore normal service. Updates will be shared as more information becomes available.
Posted Nov 10, 2025 - 11:59 PST
This incident affected: Message Delivery.