Long Code Service Degradation - US Cellular

Incident Report for Aerialink

Resolved

The 10DLC delivery hub has confirmed this issue has been resolved.
Posted Aug 22, 2025 - 10:28 CDT

Investigating

The 10DLC delivery hub has detected an issue resulting in delivery delays for MO/MT/DLR with US Cellular. We will provide more information as it becomes available.
Posted Aug 22, 2025 - 09:33 CDT
This incident affected: Message Delivery.