The toll-free delivery hub has confirmed that this issue has been resolved.
Posted Jun 06, 2025 - 08:06 CDT
Monitoring
The toll-free delivery hub is observing successful MMS delivery, and is currently monitoring. We will provide more information as it becomes available.
Posted Jun 05, 2025 - 16:15 CDT
Investigating
The toll-free delivery hub has detected an issue resulting in MMS delivery failures. We will provide more information as it becomes available.