Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 21:00 CDT
Scheduled
The toll-free delivery hub received notice that T-Mobile will be performing an unplanned maintenance on March 25, 2025, at 9 PM CDT. During this maintenance window, there may be intermittent delivery delays for SMS and MMS.
Posted Mar 25, 2025 - 08:08 CDT
This scheduled maintenance affected: Message Delivery.