Toll-Free Service Degradation

Incident Report for Aerialink

Resolved

The toll-free delivery hub has confirmed that this issue has been resolved.
Posted Mar 28, 2025 - 08:24 CDT

Investigating

The toll-free delivery hub has detected an issue resulting in SMS delays. We will provide more information as it becomes available.
Posted Mar 27, 2025 - 11:22 CDT
This incident affected: Message Delivery.