Toll-Free Service Degradation - U.S. Cellular

Incident Report for Aerialink

Resolved

The toll-free delivery hub has confirmed this issue has been resolved.
Posted Jun 18, 2025 - 08:18 CDT

Investigating

The toll-free delivery hub has detected an issue resulting in delivery failures for MMS with U.S Cellular. We will provide more information as it becomes available.
Posted Jun 17, 2025 - 14:39 CDT
This incident affected: Message Delivery.