The toll-free delivery hub has confirmed this incident has been resolved.
Posted Oct 29, 2025 - 14:52 CDT
Monitoring
The toll-free delivery hub is observing recovery in SMS delivery to small US carriers. Engineers are currently monitoring any further developments at this time.
Posted Oct 29, 2025 - 13:24 CDT
Investigating
The toll-free delivery hub is experiencing an issue resulting in SMS delivery delays to small US carriers. Engineers are currently working with the carriers for remediation. We will provide more information as it becomes available.