Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 07, 2026 - 20:01 PST
Scheduled
{{Other Carrier}} will be performing emergency maintenance impacting 10DLC MMS services.
The maintenance is scheduled to begin Saturday, January 0, 1900 at 12:00 AM PT and to finish January 0, 1900 by 12:00 AM PT. During the maintenance window, customers may experience minor latency impacting MMS messaging via 10DLC with {{Other Carrier}} subscribers.
Please see the list of impacted products and/or components below and contact the Convey Help Desk with any questions.
Posted Jan 05, 2026 - 21:40 PST
This scheduled maintenance affected: Message Delivery.